1. restored files are zero size
Symptoms
- You are backing up the entire machine or some files to any location (Cloud, local or network share).
- You restore or download an individual file from the backup, the restore operation finishes successfully without errors or warning, however, the resulting file is corrupted and is zero size.
Cause
There is a known issue with backups of systems, where Windows native Data Deduplication is enabled. Issue will be addressed in future updates.
Solution
If you are using a local or network storage as backup destination, you can mount the backup in read-only mode. Then you will be able to extract files from the Backup.
If you are backing up to Cloud, there are two options:
-
to restore the volume where the affected file resides
- to contact your service provider and check whether the entire machine recovery is available
Source: https://kb.acronis.com/content/60135
2. Using Acronis Flusher Tool
When you have difficulty to backup the machine, using flusher might resolved the issue.
1. Download the tool:
x86: http://dl2.acronis.com/u/kb/flusher2013_x86.exe
x64: http://dl2.acronis.com/u/kb/flusher2013_x64.exe
2. Run it from CMD prompt as an administrator to see if it works, save the output.
Example of normal work of the tool:
Flushing registry
Flushed reigstry for 0x80000000
Flushed reigstry for 0x80000004
Flushed reigstry for 0x80000005
Flushed reigstry for 0x80000001
Flushed reigstry for 0x80000002
Flushed reigstry for 0x80000003
All threads finished with 0
Flushing volumes
FindNextVolumeW finished for 5 volumes
Successfully flushed volume '\\?\Volume{669de034-f11f-4d7b-9859-5c1e8bc3b9a6}'
Successfully flushed volume '\\?\Volume{669de034-f11f-4d7b-9859-5c1e8bc3b9a6}'
Successfully flushed volume '\\?\Volume{669de034-f11f-4d7b-9859-5c1e8bc3b9a6}'
Successfully flushed volume '\\?\Volume{669de034-f11f-4d7b-9859-5c1e8bc3b9a6}'
Successfully flushed volume '\\?\Volume{669de034-f11f-4d7b-9859-5c1e8bc3b9a6}'
All threads finished with 0
3. If the tool works fine, set it as pre-data-capture command in the affected Backup Plan:
(as per Documentation article at https://www.acronis.com/en-us/support/documentation/AcronisBackup_12.5/#36424.html)
in the affected Backup Plan:
- save the flusher2013_x64.exe file locally on the Agent machine that performs backup activity
- open backup plan and click to "Edit"
- navigate to Backup options
Edit
- find option "Pre-post data capture commands”
- enable the Execute a command before the data capture switch
- in the field Command or batch file path on the machine with an agent, specify full path to the tool.
- Uncheck box “Fail the backup if the command execution fails”. Checkbox “Do not perform the data capture until the command execution is complete”.
4. save the change
5. Run backup and check its result.
How to check
1. Activity details -> Download Log
2. Please find the log with the word “flusher”, and the exit code = 0.
2019-08-15T15:36:38:747-07:00 4592 I00640078: Starting the before-data-capture command: c:\Users\Administrator\Downloads\flusher2013_x64.exe.
2019-08-15T15:36:40:028-07:00 4592 I00010400: Child process has exited with code '0’.
3. Acronis Connection Tool
How to use "Connection Tool"
- Download 'Windows Connection Cerification Tool' for windows pc.
https://kb.acronis.com/content/47678#Windows0
- Right click -> Extract All → Extract
- Run Command Promp
- Type in "cd Downloads\msp_port_checker_packed" then enter.
- Type in "msp_port_checker_packed.exe -u=YOURUSERNAME -p='YOURPASSWORD'" <- Please change YOURNAME and YOURPASSWORD with your password.(same credential https://us-cloud.acronis.com/
- take screen capture, start from 'Check connection to us-cloud.acronis.com:443' and send it to support.
-
Please ensure that the following ports are open for outbound:
- 443 and 8443 These ports are used for accessing the service console, registering the agents, downloading the certificates, user authorization, and downloading files from the cloud storage.
- 7770...7800 The agents use these ports to communicate with the backup management server.
- 44445 and 55556 The agents use these ports for data transfer during backup and recovery.
- 43234 The Acronis Managed Machine Service uses this port to communicate with the web console.
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